LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

HomeBug Reports

A forum topic for reporting bugs and other issues with CastleOS

Events: Cannot remove script when editing an event Messages in this topic - RSS

Phil Hawthorne
Phil Hawthorne
Posts: 400


1/30/2016
Phil Hawthorne
Phil Hawthorne
Posts: 400
When you add an event that fires a script, you can't remove that script from the event.

Scenario:

I created an event to run DemoScript.cs. I wanted to change the event time, and change the script that CastleOS executed. When I click the remove button of the script, nothing happens. I can add another script to the event, but then I can't remove either event, and am stuck with 2 events.

The only way to replace the script in the event is to create a new event.
0 link
Chris Stack
Chris Stack
Posts: 167


2/1/2016
Chris Stack
Chris Stack
Posts: 167
Phil Hawthorne wrote:
When you add an event that fires a script, you can't remove that script from the event.

Scenario:

I created an event to run DemoScript.cs. I wanted to change the event time, and change the script that CastleOS executed. When I click the remove button of the script, nothing happens. I can add another script to the event, but then I can't remove either event, and am stuck with 2 events.

The only way to replace the script in the event is to create a new event.


I have noticed similar behavior with delays, when I have a delay in an event, and I go to edit the event, I cannot remove or change the delay value. The only thing to do is delete and recreate the event, using a different delay.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390


2/2/2016
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390
Thanks for these reports. I confirmed and fixed the removal bug. However it seems the edit of the delay is working. So all should be good now. Thanks again!
0 link
Chris Stack
Chris Stack
Posts: 167


2/2/2016
Chris Stack
Chris Stack
Posts: 167
Chris Cicchitelli wrote:
Thanks for these reports. I confirmed and fixed the removal bug. However it seems the edit of the delay is working. So all should be good now. Thanks again!



Awesome!

I just checked, it does work to edit the duration of the delay. thanks for taking care of this
0 link