LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

HomeBug Reports

A forum topic for reporting bugs and other issues with CastleOS

Events: Hue device is off as condition not working Messages in this topic - RSS

Phil Hawthorne
Phil Hawthorne
Posts: 400


3/7/2016
Phil Hawthorne
Phil Hawthorne
Posts: 400
I have an event setup with the following:

1. When a sensor turns off/closes
2. Turn off a lamp
3. But only if
a) it is night
b) another lamp is off

Right now, the lamp is on, however this event is still being triggered, and hence the light I have is turning off.

I have an event for the opposite, that checks if the lamp is on. That doesn't fire, which is the correct behavior. So it seems its only the off condition which isn't working.
0 link
Phil Hawthorne
Phil Hawthorne
Posts: 400


3/8/2016
Phil Hawthorne
Phil Hawthorne
Posts: 400
As another related problem.

I have an event setup to trigger when a Hue device turns off. if that device turns off, and the time is greater than 9:45pm, then CastleOS should turn off another device.

I have the Hue bridge slowly cycle through colours of the evening. Tonight, the event has been triggered, even though the device (a Hue bloom) has not turned off. Looking at the CastleOS devices screen, CastleOS is reporting the device as on. So for some reason, CastleOS has been told that the Hue light is off, and so has turned off the Zwave switch.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390


3/8/2016
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390
Going to have to point to the Hue bridge for that one... we can only take the data it gives us. If it says a light is on or off, we'll update accordingly. We have seen it do this, where it shows the wrong state for a couple seconds before refreshing. I'm sure Philips will fix it, they are rolling out firmware updates...
0 link