LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

HomeBug Reports

A forum topic for reporting bugs and other issues with CastleOS

UPB Devices Showing Active When Not Active - Not R Messages in this topic - RSS

Gregory Martin
Gregory Martin
Posts: 21


12/20/2016
Gregory Martin
Gregory Martin
Posts: 21
I found a new bug now that UPB is partially working.....


Under Portal Active Devices, CastleOS is showing the Back Gate active and Back Porch Light, although neither is currently active, activated, or on.


When I click on the device, for example, Back Porch Light, it disappeared. Back Gate still shows active.
Now I click on Back Gate and it disappears.


Is CastleOS built to detect the state of these devices and remove them when not active from the Active Devices page in the portal?
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390


12/21/2016
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390
Hi Gregory, CastleOS does track the state when you use the devices, and the Actives screen should have devices disappear when they are removed (you can also add them to Favorites if you'd like, they aren't removed when off there).

In the log viewer, can you see if button presses on the UPB devices are being logged? Go to Menu > Settings > Menu > View Logs

Thanks!
0 link
Gregory Martin
Gregory Martin
Posts: 21


1/11/2017
Gregory Martin
Gregory Martin
Posts: 21
Yes, log viewer shows they are being logged, but looks like CastleOS doesn't understand all the return codes and ignores others. I turned this thing off almost three weeks ago because I just don't have time to beta test what is advertised as a production product.
What's it take to get an RMA for CastleHUB? This thing has to many bugs and I've not even got one thing working yet!!!
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390


1/18/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390
Hi Gregory, can you detail the codes it is not processing correctly? The UPB driver we have is solid, but it's true some things like Keypads are not yet supported. We've been working on that and the updated UPB driver, which includes support for PulseWorx, is coming at the end of the month. I want to be sure the update will include support for what you are seeing.

Thanks!
0 link
Gregory Martin
Gregory Martin
Posts: 21


1/22/2017
Gregory Martin
Gregory Martin
Posts: 21
Definitely NOT solid - you just got the UPB partially working a few days ago and this is all old UPB stuff from Simply-Automated. Nothing new and still no fix for the recommend USB UPB PIM.
-1 is the returned code on a UPB relay.
0 link
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390


1/22/2017
Chris Cicchitelli
Chris Cicchitelli
Administrator
Posts: 3390
I'm not clear what's not working about the USB PIM?
0 link