LOGIN  |  REGISTER
Smart Living Made Brilliant!
CASTLEOS FORUM

anakin

all messages by user

7/5/2013
Topic:
Installation Hang?

Adam
Adam
Andrew Steinberg wrote:
Hello. Trying out CastleOS. Just downloaded the latest. Install got to about 98%. It's sitting there at the end with a browser window open indicating there is a redirect loop. Running Win7Pro w/ SP1 w/ a few other web based services running on various ports. Suggestions? Thank you.



I have exactly the same problem. I don't think it's related to the installation. I had it working almost perfectly and then I rebooted my PC after the 1st and it no longer works. I believe it's that the trial expired on the beta after July 1st. Until the software that was promised to be released 5 days ago comes out, I'm stuck with a bunch of really expensive light switches, unless I begin setting everything back up under HouseLinc...But, now when I opened CastleOS, I got the same redirect message. Tried uninstalling and reinstalling, nothing. I think the software is coded to do that after July 1st.
7/5/2013
Topic:
When is the new software going to be released?

Adam
Adam
Hello,

My beta has expired and I would like to buy the new software. When can it be expected?

Thanks.
8/3/2013
Topic:
CastleOS closes when prox sensor is tripped

Adam
Adam
I just installed another triggerlinc and another motion detector and now whenever ANY motion detector is tripped, CastleOS core service exits out of task manager. I checked my events and nothing should be conflicting. I resynced the house in HouseLinc, and then exited the application. I've also taken the batteries out of each motion detector. I've installed and reinstalled Castle OS also. I don't see where adding 2 devices should have caused a catastrophic failure suddenly. Please advice.
edited by anakin on 8/3/2013
8/3/2013
Topic:
CastleOS closes when prox sensor is tripped

Adam
Adam
It's something in the configuration file that's gone bad. I'm resetting up everything. For the 2nd time now. First time was when the web server crashed mysteriously and I was forced to reinstall the entire OS. So, there goes my Saturday!
9/29/2013
Topic:
How to upgrade?

Adam
Adam
Chris Cicchitelli wrote:
Frank Dracman wrote:
O.k. got the license wow that's a long hash..



It's long because it has encrypted within it license information specific to you...



Translation: Don't go sharing and posting keys like a punk. Make sure the dev gets paid! Speaking of which, I just paid ya! Looking forward to the key for my house! smile
9/29/2013
Topic:
How to upgrade?

Adam
Adam
Chris Cicchitelli wrote:
Adam wrote:
Chris Cicchitelli wrote:
Frank Dracman wrote:
O.k. got the license wow that's a long hash..



It's long because it has encrypted within it license information specific to you...



Translation: Don't go sharing and posting keys like a punk. Make sure the dev gets paid! Speaking of which, I just paid ya! Looking forward to the key for my house! smile


You should now have the license key email, let me know if you don't! Thanks for your purchase!


Yep! Got it and it's all installed. What's the deal with this subscription ends 9/24/14? Will I have to buy a license annually?
9/29/2013
Topic:
How to upgrade?

Adam
Adam
Chris Cicchitelli wrote:
Adam wrote:
Chris Cicchitelli wrote:
Adam wrote:
Chris Cicchitelli wrote:
Frank Dracman wrote:
O.k. got the license wow that's a long hash..



It's long because it has encrypted within it license information specific to you...



Translation: Don't go sharing and posting keys like a punk. Make sure the dev gets paid! Speaking of which, I just paid ya! Looking forward to the key for my house! smile


You should now have the license key email, let me know if you don't! Thanks for your purchase!


Yep! Got it and it's all installed. What's the deal with this subscription ends 9/24/14? Will I have to buy a license annually?



That's the upgrade subscription (which yes you can renew annually). The version you purchase, and any upgrade you get during your eligible period, you can run forever.



Ahhh okay, that's a fair deal indeed. I'd be down for an annual subscription if it were comparable to the price I paid. smile

Also, I found a quick fix for that bug I mailed you about a couple times. If I turn the lights on and off a couple times though the web interface, it resolves the problem with the PIRs crashing Castle. It seems to have been related to the state that Castle thinks the switches are in versus their actual state. Cycling the switches sort of resyncs everything and then it's all happy. I'm going to sleep, but I can email you later if you'd like more detail. Thanks for everything!
5/9/2015
Topic:
Squeezebox Support

Adam
Adam
I second that, I would love squeezebox support... And there are many open-source resources /tools online. Squeezebox is super powerful.
5/10/2015
Topic:
Squeezebox Support

Adam
Adam
I don't offhand, however I believe this is a good starting place.

http://wiki.slimdevices.com/

However, there are other ways to accomplish controlling the system by simply enabling CastleOS to send keystrokes to either a locally running (already existing) player app, or to the IP of a squeezebox on the network. (Similar to what you do with Directv control) It is my belief that it would be impossible to have squeezebox output voice responses - like SONOS. Squeezebox sorta just points to a url and plays it... So it would require squeezebox to always be set to a loopback to linein, or the stereo mix in Windows. Probably more work than it's worth, and I think we (the users) could probably do that right now, if so inclined. However, if you have 10 min for a call, I would be happy to give you my idea. I think it would be fairly simple to implement control over squeezebox...
edited by anakin on 5/10/2015
edited by anakin on 5/10/2015
7/1/2016
Topic:
CPU usage of core....

Adam
Adam
Is there an update with this bug patched? I am using the insteon hub 2,and emailed you 2 weeks ago with logs, but haven't heard back. I believe I am also affected by this bug.
7/6/2016
Topic:
CPU usage of core....

Adam
Adam
Any word on the bug fix? This thread is awfully quiet. I haven't had CastleOS working in about a month. Should I throw my system in the trash, ask for a refund of the license I bought, which no longer works, and just link lights to motion detectors to turn on? It's really insulting that no support can be found for a product in our homes, which we all supported you on. Some of us, like myself from betas back four years ago, and my system has been intermittent at best. It would be appreciated to at least get a response, good or bad, as to when this issue will be rectified.
7/8/2016
Topic:
CPU usage of core....

Adam
Adam
That's good to hear. I was just researching how to switch over from CastleOS as my controller to my Insteon Hub. I wrote a batch file to stop, and start the CastleOS service, and run it every hour via Task Scheduler, however it does not resolve the issue. My system works well for approximately 15 minutes after restart of service before it goes back to having delayed, or missed events. Would it be possible to try the latest beta early? I check the Google Docs beta channel daily, but it has been a while since a private beta has been released. I'm pretty desperate to have a working system again. Thanks.
7/24/2016
Topic:
CPU usage of core....

Adam
Adam
Dude, I'm right there with you. My system has been dead for well over a month, with no support, I'd like to point out. I've been considering the same thing, why don't I just abandon castleos for an isy, and cut my losses. I've been beyond disappointed with CastleOS. If you're going to switch, I'd post a video to YouTube of how broken your system is. With nothing working, no support, and a ghost town of a thread, I've about had it. The features in 2.0 have been promised for over 2 years, and I'm just hanging on waiting to see if this illustrious 2.0 version will resolve my issues, and finally give me the working system that I was promised when I adopted CastleOS 4 years ago, or so. This has been a colossal waste of a touch screen pc, Microsoft Kinect (which has now been replaced by an Amazon Echo, and Insteon Hub), and of course the cost of the CastleOS license which I apparently cannot get support for, in order for it to even work poorly, let alone, work at all. My last post is about 14 days old, with no answer. So, believe me, you are not alone. I assume there aren't more posts like ours, as many people have just abandoned the platform.
7/25/2016
Topic:
CPU usage of core....

Adam
Adam
Oh, yah... I can't get devices or events to delete. I end up renaming them, and clearing the device ID to all 0s, or set the event to have no actions, or conditions. That's the work around. But, it doesn't matter now, because my system barely ever works, and I usually end up unplugging my Hub bc the actions are so delayed, and I don't want lights turning on when I leave the house etc. It's real fun, tripping in the dark, lights blinding me in the morning unexpectedly turning on to full brightness, etc. I broke a glass setting it down in the sink because I stupidly was too lazy to turn on my own lights, since CastleOS can't anymore! If nothing is working at all, then it just means that it's working perfectly. It's not a bug, it's a feature at this point.
7/26/2016
Topic:
CPU usage of core....

Adam
Adam
Yes, that would be terrific. I am free after 4:30pm EST, and probably over the weekend. Please let me know when you think you may be available, and I will coordinate accordingly. I am wondering if the 2.0 release will resolve the issues. The system works seemingly well at times, and then doesn't for other periods of time. For instance if one PIR turns on a set of lights, it will be instantaneous, and then when another PIR is to trigger another set of lights, it will be significantly delayed. Then, subsequent events are very delayed as well. Thank you.
7/26/2016
Topic:
CPU usage of core....

Adam
Adam
I'm available now going on all night, if you're free.
7/26/2016
Topic:
CPU usage of core....

Adam
Adam
Request created
10/20/2016
Topic:
Latest Beta Pegging CastleHub's CPU

Adam
Adam
I have the same issue, but my Kinect service is disable, as is Bloomsky. However, I now have CastleOS disabled as well, as it does not work for me. Any update on when the version with the new Insteon hub2 driver will be released?
10/20/2016
Topic:
Latest Beta Pegging CastleHub's CPU

Adam
Adam
I do not have any Sonos, or any other protocol enabled. I only have Insteon enabled.
10/20/2016
Topic:
Latest Beta Pegging CastleHub's CPU

Adam
Adam
I have. I install the new betas hours after they are posted. I check daily. The system works OK for maybe an hour before it becomes unresponsive.
12